SAP Knowledge Base Article - Public

2543362 - Search on Sub-Territories Includes Wrong Data

Symptom

The Account advanced search on sub-territories includes wrong data when a territory name matches with another territory's ID.

Environment

SAP Sales Cloud

Reproducing the Issue

  1. Go to Customers work center.
  2. Go to Accounts view.
  3. Click on Advanced Search button.
  4. Under Team --> Territory search for territory 123 (123 represents the name of the territory).
  5. Check the box Include Sub-Territories.

Result: Advanced search with sub-territory includes wrong data. It includes a territory that matches with another territory's ID; however, it's not a sub-territory of 123.

Cause

As the Sub-Territories is an identifier field, it will search against both ID and description.

Resolution

This is the system expected behavior.

If you wish this to be changed please check the Influence forum to submit an idea: https://influence.sap.com/SAPCloudforCustomer

Keywords

territory, name, id, search, sub-territories , KBA , LOD-CRM-TM , Territory Management , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions