Symptom
You are adding accounts via proposed visit in a Route and see that Visit-By Date field is empty
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Visits work center
- Select Routes view
- Select Show All and find forthe Route ABC (Where ABC is the name of the route)
- Click in Add in the proposed visits pane
- From the value help, try filtering for accounts based on any criteria
You will notice that the Visit-By date field for the accounts of the Proposed Visits is empty.
Cause
If you create a route for a particular sales area, then visit by date will be shown only if you have a visit before date maintained for account respect to that sales area. In order to check the same, you need to follow the steps below
- Go to Customers Workcenter
- Go to Accounts View
- Select show All and find for the account
- Navigate to facet Visits By Sales Area
If Visit Before for the corresponding sales area (combination of Sales Organization, Distribution Channel, Division ) is not maintained then it will be empty.
Resolution
This is the standard behavior of the system.
If the feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available.
An alternative option may be to check the corresponding SAP Customer Influence Site to submit an idea:
See Also
Keywords
KBA , LOD-CRM-ACT-VST , Visit Planning , How To