Symptom
When filtering with query 'My Accounts' in work center Customers, view Accounts, the user is able to see all Accounts in his Territory, even those for which he is not assigned to the Account's Team.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Customers work center.
- Go to the Accounts view.
- Select filter option 'My Accounts.'
- The result list displays all Accounts for which the user is part of the Account's Team or the Territory Team.
You expect to see only the Accounts for which the user is part of the Account's Team.
Cause
This is the expected system behaviour. Filter My Accounts shows Accounts for which the user is assigned either to the Account Team or part of the Territory Team in one of the territories assigned to the account. Please mind that there is not an automatic resolution of the account hierarchy: this can be achieved by setting the advanced search parameter 'Include Sub-Territories'.
Resolution
To filter for Accounts for which the user is only part of the Accounts Team, you can create custom filter query.
- Log in as an Administrator.
- Go to the Customers work center.
- Go to the Accounts view.
- Select Adapt and Edit Master Layout.
- Select Show Advanced Filter.
- Go to the Team section of the screen.
- Select Add Items button and Add Fields option.
- Select fields Responsibility Source and Party Role, and select Apply.
- Select Adapt and End Layout Changes.
- Fields are now visible under the Team section.
To save and run the query:
- For the field Responsibility Source select option Account Team Only.
- For the field Party Role select option Account Team Member.
- Select Save Query button.
- Provide the name of the query and select Apply.
- The query is now available from the dropdown list of the filters.
See Also
- SAP Help Portal: Territory Management
- KBA 2642080 - 'My Accounts' and 'My Accounts With No Visits Planned' in Visit Planner
Keywords
My Accounts, Filter, Accounts. , KBA , LOD-CRM-ACC , Account , How To