Symptom
- Report exported from the report preview screen using the 'Export to Excel, CSV' option always gets sent as a background job
- How do I download the output?
- Is there a way to skip the background job and get the export directly from the preview?
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors HCM Suite
- Online Report Designer
- Report Center: Report - Canvas
Reproducing the Issue
Instances without Report Center:
- Access the Report from the ORD menu Menu
- Export to Excel / CSV
- No actions seem to have been taken
Unable to see if the download has started or completed.
Instances with Report Center:
- Navigate to Reporting
- Select the desired Canvas Report and Run it
- Instead of exporting the file, you get a message similar to the following, although you hadn't actually scheduled anything:
" 'Report Name - Page #' is successfully scheduled. You can find it in View Schedules "
Example:
Cause
This is expected behavior.
To avoid holding up browser resources and user session(s) exports will always be sent as a background job.
This will be the behaviour, irrespective of the report's size.
i.e. A report export with just one column and one row will also be sent as a background job
Resolution
Downloading the export:
Instances without Report Center:
- Expand the 'Report Distributor Downloads' menu
- Checking the status of the export job:
Report distributor job status Yellow, Green, Red and Aborted
Clicking a completed job will allow the user to download the output file.
Instances with Report Center:
- Navigate to View Schedules and wait for the 'Status' of the job you just exported, to change to 'Completed'
- Once completed, expand the Action menu and click 'Download' to export the report's output
Keywords
Export, Excel, CSV, download, Online, Report, Designer, center, canvas, export, background, schedule, preview, always, offline , KBA , LOD-SF-ANA-ORD , Online Report Designer , How To