SAP Knowledge Base Article - Public

2543851 - Extension Fields Missing in Rule Editor

Symptom

You notice that some of extension fields (Key User Tool created Z-Fields) do not appear in the Rule Editor.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Customers work center.
  2. Open the Accounts view.
  3. Open any Account.
  4. Go to Sales Data.
  5. Click Edit.
  6. Go to Adapt mode.
  7. In the Rule Editor you notice that some KUT fields are missing.

Cause

The system only shows the fields which are:

  • Available in the Header section and fields available in the first loaded facet.  
  • Fields enabled for offline usage (with OCM binding).
  • Only fields on Root node that have 1:1 association. Fields having 1:N association and are on some other node will not appear. So KUT fields created directly on BO-Root node, will be available, otherwise not.
  • List fields are not supported.

Resolution

An option may be to check the SAP Cloud for Customer Ideas Forum to submit an idea: SAP Cloud For Customer Influence

Keywords

List field, KUT, Rule Editor , KBA , AP-RC-UIF-FLX , Page Layout & Key User Configuration , Product Enhancement

Product

SAP Cloud for Customer core applications all versions ; SAP Hybris Cloud for Customer add-ins 1708