Symptom
You notice that some of extension fields (Key User Tool created Z-Fields) do not appear in the Rule Editor.
Environment
SAP Cloud for Customer
Reproducing the Issue
Steps to reproduce:
- Go to the Customers work center.
- Open the Accounts view.
- Open any Account.
- Go to Sales Data.
- Click Edit.
- Go to Adapt mode.
- In the Rule Editor you notice that some KUT fields are missing.
Cause
The system only shows the fields which are:
- Available in the Header section and fields available in the first loaded facet.
- Fields enabled for offline usage (with OCM binding).
- Only fields on Root node that have 1:1 association. Fields having 1:N association and are on some other node will not appear. So KUT fields created directly on BO-Root node, will be available, otherwise not.
- List fields are not supported.
Resolution
If you need a feature which is not available, please follow:
1. If you are a partner: please use cloudsolutionpartner@sap.com or the Partnerfinder
2. If you are a customer:
- Contact your Account Executive.
- Check the link for SAP Advisory Services.
An alternative option may be to check the SAP Cloud for Customer Customer Influence to submit an idea:
Keywords
List field, KUT, Rule Editor , KBA , AP-RC-UIF-FLX , Page Layout & Key User Configuration , Product Enhancement
Product
SAP Cloud for Customer core applications all versions ; SAP Hybris Cloud for Customer add-ins 1708