SAP Knowledge Base Article - Public

2543926 - Unable to sign-in to career portal or submit application due to ‘URI is not absolute’ error

Symptom

An external candidate is not able to log-in or submit an application through the external career site due to an application error with error code “URI is not absolute”.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SuccessFactors Recruiting Management

SuccessFactors Recruiting Marketing

Reproducing the Issue

  1. Launch the RCM or RMK external career site.
  2. Click on Sign-in button, or Search jobs >> Select a Job >> Apply.
  3. An application error message appears.

hydro.png

Cause

The RMK Portal URL and RMK Job Search URL from the Configure Recruiting Marketing Datacenter URL does not have an “https://” tag.

Resolution

  1. Raise a COSR ticket to Operations team to request for the server logs. Provide the System info/details indicated in the application error message (Release, Server, Request, Timestamp) as well as the customer’s company ID and data center location.
  2. Check and validate if the logs contain any error which reads the following error code: hydro2.png
  3. Check the configuration in Provisioning >> Manage Recruiting >> Configure Recruiting Marketing Datacenter URL
  4. Make sure that there is an “https://” tag in the RMK Portal URL and RMK Job Search URL.

This can be completed by Professional Services or a partner in provisioning. If a customer, please contact your Implementation Team.

Keywords

URI is not absolute, Career site, Application error , KBA , LOD-SF-RMK , Recruiting Marketing , LOD-SF-RCM , Recruiting Management , Problem

Product

SAP SuccessFactors Recruiting all versions