Symptom
Users report that when clicking on the link to access a survey that is required for the item completion: nothing happens, they are not directed to the survey.
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Environment
SAP SuccessFactors Learning
Reproducing the Issue
-
Schedule an Item classified as Instructor Led Training that has a survey attached to it >
- Make sure the survey has a number of days filled in Options Tab > Field "Days to complete" >
OR that this setting is populated on the item level (Item record > Related/More > Surveys Tab):
Please make sure to fullfil one of the above fields or to maintain both with same number. - Enroll users and allow them to attend the course
- After the completion of the course: the item completion is pending the survey being answered by the user
- After a certain amount of time, the user clicks the survey to complete it but nothing happens and the user cannot complete it.
Cause
One of the causes for this issue is that the limit of time granted to the user for completing the survey is already expired.
Resolution
As per the Online Help, the setting "days to complete" is used to define "the days between the time that users complete the learning item and the deadline to complete the survey. If users do not complete the survey in that amount of time, then the system makes the survey unavailable and the associated learning item remains in a pending state until an administrator records its completion."
In this scenario, this is an expected behavior and the administrator will need to record the completion of the item so the item can be moved to the Learning History for the user.
Keywords
feedback, completion, pending, evaluation, questionnaire, survey, ilt, class , KBA , LOD-SF-LMS-EVA , Surveys , LOD-SF-LMS , Learning Management System , LOD-SF-LMS-SCH , Class - Scheduled Offerings , LOD-SF-LMS-USR , User Entity , How To