SAP Knowledge Base Article - Public

2545105 - Exporting data from Advanced Reporting fails with Application error

Symptom

• Users are unable to export data from Advanced Reporting.  
• After clicking the export/download button, a new pop-up window appears.  
• The pop-up window eventually displays a connection error. 

Environment

SuccessFactors Advanced Reporting

Reproducing the Issue

  1.  Access Advanced Reporting
    Analytics > Analytics / Reports > Advanced Reporting
  2. Create a new query or open an existing one.
  3. Try exporting the query's output.

    Export.png

  4. A popup window opens and displays an error after a while.

    error.png

Cause

• The behavior is expected.  
• Advanced Reporting is a query designer and is intended to be used only to design and preview queries.  
• It is not designed to export data.  
• Exporting data is only supported for preview purposes and works for smaller queries.  
• Queries with large data or complex calculations take significantly more time and result in a browser timeout.  

Resolution

Please create a new Report-Canvas and add the Advanced Reporting query as List report component to it.

Even for reports, we suggest using the Run-Offline option (Preview the report and Run-Offline) or scheduling them if the report contains significantly huge data.

https://help.sap.com/doc/4f3cf9444a324d65957e93aef45633a6/latest/en-US/SF_EC_Adv_Rep_ORD_en.pdf


Scheduling Reports for offline run using the report distributor:
Report Distributor How to Schedule it

Scheduling Reports using the report center:
2464604 - Scheduling Reports In Report Center


Keywords

Export, Advance, report, canvas, Application, Error, Connection, Timeout, Connection reset, Query, designer , KBA , ss_anonymizedkba , LOD-SF-ANA-ADV , Advanced Reporting (ODS) , Problem

Product

SAP SuccessFactors HCM Suite all versions