Symptom
You need to delete an attachment from a Supplier Invoice although the Delete button is grayed out.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Supplier Invoicing Work Center.
- Go to Invoices and Credit Memos View.
- Select the affected Supplier Invoice and click Edit.
- Go to Attachments tab.
Here you will see that the Delete button is grayed out.
Cause
The affected Supplier Invoice is currently in Paid or posted status. This means that all the Financial documents have already been sent. Hence, you will not be able to delete the attachment that is in the invoice.
Also, attachments are crucial information for invoice approval purposes and for future auditing. Hence, if the attachment is deleted after the Invoice is posted/paid, then critical information will be lost.
It is the standard system functionality that it will not allow you to Delete and Replace the attachments once the Invoice gets Posted or Paid. The Delete and Replace buttons will be grayed out in such cases.
However, it is possible to delete/replace the attachments when the supplier invoice is still In Process or In Approval status.
Resolution
This is the expected system behavior. It should not be possible to delete attachment in an invoice that is already posted since it could cause several inconsistencies.
If the Supplier Invoice is Paid or Posted, the Delete option for the attachements will be greyed out and it cannot be deleted. Hence , we suggest to cancel the Supplier Invoice and create a new Supplier Invoice with the valid attachments , if the attachements included are wrong or if there is any requirement to change the attachement.
Keywords
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