Symptom
- Customer wants to mass update the email of all Onboarding 1.0 users by a script in back end.
- Mail notifications are being received by users / candidates in Test / Stage instance (for testing purposes).
Environment
- SAP SuccessFactors Onboarding 1.0 All versions
Cause
- Personal or enterprise mail are configured for users / candidates.
- Mailing Options are enabled in Super Admin.
- Email address of the affected user may be setup in the "Default Email Address" field in Mailing Options in Super Admin.
Resolution
- In Super Admin, go to Mailing Options of your Instance.
- Check if "Mail Redirecting Enabled" option is ticked. If this is not enabled, it will be sent to the respective mail of the user / candidate.
- Check the value of the "Default Email Address" field. Note that if the option in Item # 2 is checked, all mail notifications will be sent to the mail specified in the "Default Email Address" field.
Note: The proper approach is to use "Mailing Options". It is not suggested to use a script to mass update the email of all users.
Here are the following reasons why:
- There is already an existing feature in Super Admin which caters this purpose.
- Running a script will change the database directly which is very difficult to restore in case of any problems.
- All new hires that will be created after running the script will not be affected. Thus, resulting to the same problem.
Keywords
Notifications; emails; onboarding 1.0; mailing options; mass update; script; back end , KBA , LOD-SF-OBD , Onboarding , How To
Product
SAP SuccessFactors Onboarding