Symptom
-
The report is showing the wrong balance value for some account types
- The Time Off portlet is showing different balance values than the reports
Environment
SAP SuccessFactors HXM Suite
Cause
-
The report is not configured properly
- The data export of the Time Account object does not match the values available in the portlet, but it matches the value in the report
Resolution
The report is not configured properly
Consider the following items when creating the report:
- Date options of the tables
- Filters on account type, employee status, pay component, booking type, etc.
- The Time Off portlet only displays active accounts. However, the report can show all accounts regardless the status.
In this case, you need to apply a filter to get only active time accounts (e.g. mdfSystemStatus in A)
The data export of the Time Account object does not match the values available in the portlet, but it matches the value in the report
Export the Time Off data and check the external code of the account type:
- Check the balance available in the Time Off portlet
- Go to Admin Center > Export Data > Select Generic Object "Time Account" > Click on Export button
- Go to Monitor Job page to download the file
- If you do not have the external code of the account type, open the Time Account.csv (if you already have, jump to step 6)
- Filter by userid and copy the external code of the account type
- Now open the Time Account-Time Account Details.csv, filter by the external code and sum the "timeAccountDetails.bookingAmount" column
- Compare the sum of the "timeAccountDetails.bookingAmount" to the balance available in the Time Off portlet.
- If they do not match, check if Simulate Accruals is set to 'Yes' on the time account type of the time account. If this is enabled, it is expected to see accruals as part of the account balance on Time Off, however, this would not be pulled by the report due to reporting product limitation. See 2377364 - Advanced Reporting - Time account - Time OFF with Simulated Accrual values - Limitation explained
- If they match, you need to check the report configuration.
Please see EC Time Off Implementation guide for this expected behavior in report:
See Also
Keywords
Time Off Advanced Reporting report account type balance export data value time management incorrect different date EC not the same , KBA , LOD-SF-ANA , Analytics & Reporting (Ad Hoc, YouCalc, ORD) , LOD-SF-EC , Employee Central , How To