Symptom
We noticed that the Object Details link is no longer visible on the user's Learning Plan after the item was removed by the user.
Environment
All SF LMS versions.
Reproducing the Issue
1) As a user, assign to oneself an online item (preferably one that is set to lock after a specific number of attempts).
2) As the same user (in Step 1), reach the maximum number of attempts by failing to complete the item.
3) As the same user (in Step 1), remove the item from your learning plan once it shows as locked in your Learning Plan - see screenshot below for reference.
4) As the same user (in Step 1), reassign the same item to oneself.
Cause
The reason why the Object Details link is missing is because the item is set to record learning when the user fails it - see screenshot below.
Resolution
Since the user's progress is tied to the user's failure (due to the item's setting above), the Object Details link can be made available again by removing the user's failure attempt. This can be accomplished using the Learning Event Editor tool - see screenshot below for reference.
Keywords
Object Details Missing
Object Details Disappeared
Object Details No Longer Visible , KBA , LOD-SF-LMS-COR , LMS Core - Items, Catalog, Curricula , LOD-SF-LMS-PQE , LMS Plateau Question Editor and Evaluation , Problem
Product
Attachments
HR-DeleteLearningEvent.png |
HR-RecordLearningWhenFailed.png |
HR-RemoveLockedItem.png |