Symptom
Workflow configuration is enabled for a specific Time Type. The below situations can arise:
- The system is triggering the workflow only if an employee requests their own Time Off but not if the Manager or Admin User is requesting on their behalf.
- The system is triggering the workflow only if a Manager or Admin User requests Time Off for the employee but not if the employee is requesting Time Off.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors Employee Central
- SAP SuccessFactors HXM Suite
Reproducing the Issue
- Go to Admin Center
- Search for "Manage Time Off Structures"
- Select "Time Type" for first dropdown and select the Time Type where you need to configure the workflow
- Select Take Action -> Make Correction
- In the option "Workflow Configuration" select the workflow you have previously created and save it.
- Proxy as the Employee and go to Time Off
- Request a leave, select the period and submit it. The system will trigger the workflow you configured under the Time Type.
- Proxy as the administrator or Manager, perform the same process, no workflow is being triggered.
Cause
This can be caused by either:
- The fields "Admin Workflow Configuration" and "Workflow Configuration" are not configured correctly on the Time Type.
OR
- The "Employee Time" rule also may be configured incorrectly.
Resolution
- Go to Admin Center
- Search for "Manage Time Off Structures"
- Select "Time Type" for first dropdown and select the Time Type where you have configured the previous workflow
- Select Take Action > Make Correction
- The option "Admin Workflow Configuration" is not filled out. Select a workflow for this option and save it. This workflow will trigger if the initiator is not the employee:
- If this does not fix the issue, it means that the rule that will trigger a workflow under "Employee Time" Object is not correct.
- Follow the next steps in order to correct the issue:
- Go to Admin Center
- Search for "Configure Object Definition"
- Select object, then search for Employee Time (EmployeeTime)
- Go to Rules Section at the bottom of the page and open the rule related to workflow
- The rule does not specify what workflow the system will trigger in case the user that is logged in is not the employee
Example:
You need to add an "else" condition and it will look similar to this rule:
For simple scenario's where you want to trigger a workflow for admin or managers submitting leave for employee's, have a basic rule to trigger the workflow mentioned on the field admin workflow configuration.
For complex scenario's, a rule with a different workflow to cover different complex scenario's is covered.
You must always have a value in the admin workflow configuration field, but in this scenario the onSave rule can trigger which ever set of workflows you need.
You should always have a catch all in this rule though that points back to the workflow in this field.
It is to ensure consistency and ensures that a workflow is triggered that matches what is on the time type.
See Also
- 2318854 - Employee Central - Time Off
- Configuring Workflows in Time Off
Keywords
SF, Success Factors, EC, workflow, admin workflow, time type workflow, time off, manager, user , KBA , LOD-SF-EC-TIM-WAN , Workflows - Alerts - Notifications , How To