SAP Knowledge Base Article - Public

2548626 - Scheduled Workflow Log

Symptom

On rescheduling a scheduled workflow , new rescheduled logs  will not be seen , this is because the rescheduled workflow gets updated to the existing scheduled workflow rule.

Reproducing the Issue

Create a scheduled workflow which gets scheduled on change of Sales Quote business object.

  1. Now navigate to Sales Workcenter
  2. Then to Sales Quote View
  3. Open a Sales Quote ABC, where, ABC is any Sales Quote
  4. Make changes to Sales Quote as  per condition set in workflow 
  5. Now when  the condition is satisfied the workflow gets scheduled to execute
  6. The  scheduled workflow to execute could be seen in Workflow Changes facet of Sales Quote
  7. Meanwhile, change the Sales Quote  again to satisfy the condition set and then save
  8. The  new scheduled workflow will not be seen under Workflow Changes facet of Sales Quote

Cause

 This is because the rescheduled workflow gets updated to the existing scheduled workflow rule. Hence you will not see the new date of rescheduled workflow.

Resolution

As of now this is the expected system behaviour

Keywords

KBA , LOD-CRM-EMP , Employee , How To

Product

SAP Cloud for Customer core applications 1708 ; SAP Hybris Cloud for Customer add-ins 1708