Symptom
This KBA highlights the behaviour of HRIS sync mappings and mandatory fileds between EC and EP fields when the follow error occurs
Environment
- SAP SuccessFactors HXM Suite
- SAP SuccessFactors Employee Central - Business Configuration
Reproducing the Issue
- Admin Centre
- Go to Manage Business Configuration
- Make a Change to any Field or Element
- Click Save
Cause
The EP field in a HRIS Sync Mapping cannot be set to mandatory/required
This error message will appear in Manage Business Configuration in the given scenario's
- HRIS field is non mandatory/ and the Standard Element is set to Mandatory/Required
- If both the HRIS Field and the Standard Element are set to Mandatory/Required
Resolution
To resolve this issue, please do the following
- Download the Succession Data Model from Provisioing
- Look for the standard element field that the error message referred to, in this case timeZone
- Either change the required value to false (as shown in below screen shot) or remove the required tag
If the above does not resolve the issue, do the following:
- Export Succession Data Model (SDM).
- Change required=true for the impacted field in both Job Information and Standard Element sections.
- Import modified SDM.
- Test if the issue is resolved in Manage Business Configuration UI (BCUI).
- If it’s resolved, make required=false for the impacted field in both the sections and re-import the data model.
As a customer, you do not have access to Provisioning. To complete tasks in Provisioning, contact SAP Cloud Support.
Keywords
Error When Saving Manage Business Configuration, Field can not be Mapped to a Mandatory Standard Element, Mandatory Standard Element, Remove the Mapping, BCUI, HRIS Sync Mapping, Required ="true", Mandatory, HRIS sync error , KBA , LOD-SF-EC-BCI , Manage Business Configuration (BCUI) & Data Models (XML) , LOD-SF-EC-HRS , HRIS Sync , Problem