SAP Knowledge Base Article - Public

2548822 - Completed Survey Answers Are Still Editable

Symptom

You answered and submitted a survey. You are still able to edit its answers after the status of the survey is 'Completed'.

Environment

SAP Cloud for Customer

Reproducing the Issue

Below example is for a survey from a Service scenario. However, Sales scenarios (such as a opportunity survey) are applicable also.

Prerequisite: you have completed and submitted the survey of ticket ABC (ABC represents the ticket ID).

  1. Go to the Service workcenter.
  2. Go to the Work Tickets view.
  3. Open ticket ABC.
  4. Go to the Surveys tab.
  5. Click the Survey hyperlink that has its status as completed.

You can still change the answers and submit them again.

Cause

Currently we do not have a lock status for completed surveys. It can be changed anytime. This is intended for flexibility reasons, where you could can back and answer the same survey again.

Resolution

If the feature/functionality is needed as a matter of urgency, please refer to KBA 3475641 - Functionality Currently not Available

Keywords

Survey ; Service ; Sales; Product ; Editable ; Changeable ; , KBA , LOD-LE-SUR-EXE , Survey execution = runtime , LOD-CRM-SRP , Service Request Processing , LOD-CRM-OPP , Opportunity Management , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions