Symptom
Read only access not possible for the catalogs SAP_CORE_BC_IAM_RA, SAP_CORE_BC_IAM_RM, and SAP_CORE_BC_IAM_UM which are used for the IAM apps
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- In the Maintain Business Roles app create a new business role
- Assign one of the catalogs listed above to this business role
- In the Maintain General Restrictions section choose the option for no write access for this catalog
- Users with this role will still be able to make changes in the apps like Maintain Business Users
Cause
- Some apps have no field restriction options
- This is expected behaviour for these catalogs
Resolution
- Go back to the Maintain General Restrictions section in Maintain Business Roles
- Choose the option as restricted for write access
- This would typically let you adjust which fields are restricted for this catalog
- Catalogs with no fields displayed here, do not have the option to restrict fields, or be read only
Keywords
SAP_CORE_BC_IAM restrictions readonly read only write access role Maintain Users IAM catalog , KBA , BC-SRV-APS-IAM , Identity and Access Management , Problem
Product
SAP S/4HANA Cloud 1708