SAP Knowledge Base Article - Public

2550264 - The system is not set up for translation, system supported translation languages are not installed

Symptom

You will receive the below error message while attempting to translate an item of your add-on within the SAP Cloud Applications Studio on a production tenant:

The system is not set up for translation, system supported translation languages are not installed

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental." 

Environment

  • SAP Cloud Applications Studio
  • SAP Cloud for Customer
  • SAP Business ByDesign

Reproducing the Issue

  1. Login to Cloud Applications Studio on your production tenant.
  2. Open the affected Solution.
  3. Right click on the item (e.g. a .codelist file)
  4. Select Translation > Export Text.
  5. Below error message appears.

 cd1.PNG

Cause

It is not possible to export texts from a live system i.e. production system.

Resolution

The translation should be performed on the test/development system where the patch solution is developed.

See Also

Please refer to the Help portal documentation: Translation Quick Guide 

Keywords

PDI, SDK, translate, export, text, system, is, not, set, up, for, translation , KBA , AP-RC-BDS-TRANSL , ByDesign Studio Translation , How To

Product

SAP Business ByDesign all versions ; SAP Cloud Applications Studio all versions ; SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions