SAP Knowledge Base Article - Public

2550419 - End Customer Not Getting Determined in a Sales Order

Symptom

You have configured the role "End Customer" in Involved Parties of Sales Order activity in Business Configuration. When you try adding the role "End Customer" and select the role from the dropdown list in the Involved Parties facet of the Sales Order, the End Customer does not get populated automatically.

Reproducing the Issue

  1. Go to Sales Workcenter
  2. Navigate to Sales Order view
  3. Open the Sales Order ABC
  4. Go to the Involved Parties facet
  5. Click on Add
  6. Select the role End Customer from the dropdown
  7. You can see that the End Customer is not determined automatically

Cause

In the Involved Parties Determination for Sales Order, the End Customer is being determined from the Business Partner Relationship with the Account.

Resolution

1. Open the Account 123.
2. Go to the Relationships facet.
3. Click Add.
4. Select the Relationship Type "Has End Customer" .
5. Enter the End Customer as Business Partner.
6. Click Add and Save.
7. Go to the Involved Parties facet in the Sales Order ABC and Refresh.

End Customer - SO CD.jpg

You will now see the End Customer being determined as per the determination maintained in Business Configuration.

Keywords

KBA , AP-SLO , Sales Order Processing , How To

Product

SAP Cloud for Customer core applications 1708 ; SAP Cloud for Customer core applications 1711 ; SAP Hybris Cloud for Customer add-ins 1708 ; SAP Hybris Cloud for Customer add-ins 1711