Symptom
You are replicating Visits from CRM to C4C and the confirmation IDOC coming from C4C fails in CRM with the error: 'No valid Document/Transaction Header could be determined'.
Reproducing the Issue
Create a Visit in CRM and replicate it to C4C. If the Visit is created properly, a confirmation is sent back to CRM but the IDOC fails in CRM with the error: 'No valid Document/Transaction Header could be determined'.
Cause
The issue is cause because Visits created in C4C will have a default Processing Type code as 0001 similar to Appointments.
Due to this, when creating a Visit and replicating it, the code list mapping that will be taken will be the 0001 Appointment local code and external code ABC (ABC represents appointment external code) which is the Documet Type for external system.
But the External system expects XYZ for visits not ABC.
Resolution
The issue can be solved by the below Logic:
When you create a Visit in C4C you need to use the the code list mapping for Data type BusinessTransactionDocumentProcessingTypeCode.
Map local Code 0001 to XYZ external code for Visits in CRM.
Now, if you are replicating Appointments as well, you need to create a custom document type for Appointments: in the Business configuration work center open the activity list and search the activity Activities.
Then create Apointments only with this custom document type and map in code list mapping for Data type BusinessTransactionDocumentProcessingTypeCode the custom code to the external code used in CRM for appointments.
Keywords
KBA , LOD-CRM-ACT-VST , Visit Planning , How To