Symptom
You noticed that e-mails sent are truncated/cut when you click reply from C4C using the Microsoft Outlook Add-In. This does not happen when the reply is done directly from SAP C4C.
Environment
SAP Cloud for Customer core applications
Reproducing the Issue
- Go to the Service work center.
- Go to the Tickets view.
- Search and open ticket XXX (XXX represents the ID of the ticket).
- Press the Reply button and make sure that the checkbox "" is checked.
- The mail is copied into MsOutlook, however, it is truncated/cutted.
Cause
- The issue occurs because when using C4C and Microsoft Outlook Add-In, and is caused due to a limit of 2000 characters on average in mailto Microsoft's protocol.
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This 3rd party solution uses a URL convention/standard, and is not within the scope of SAP to control or handle.
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The above is not an issue/limitation from SAP's end, but is rather a limitation imposed by the browser conventions followed.
Resolution
- This is the system standard behavior. The 2000 characters limit includes spaces and other special characters. Please note that space is considered as '%20' which is a total of 3 characters.
- This feature is not supported in the current release of SAP Cloud for Customer/SAP Business ByDesign.
- If the feature/functionality is needed as a matter of urgency, please refer to KBA 3475641 - Functionality Currently not Available.
Keywords
Cut prune trim cutoff clipped chopped text e-mail body add-in Microsoft , KBA , LOD-CRM-SRP-INT , Ticket Interactions , LOD-CRM-SRP , Service Request Processing , Product Enhancement
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions