SAP Knowledge Base Article - Public

2551446 - Only One Business Partner Returned via SOAP for Multiple Party Roles in Ticket via QueryServiceRequestIn

Symptom

You've maintaned multiple Business Partners for the same Party Role in a Ticket, e.g., two service technicians, but when you perform a query with the WSDL QueryServiceRequestIn, the system only returns one Business Partner.

Environment

SAP Cloud for Customer

Reproducing the Issue

As example, we'll consider that you've submitted the below payload to query the involved parties of the ticket 123 (123 represents the ticket ID):

payload1.jpg

  1.  Submit the above payload.
  2.  The reply only returned the business partner 456789 (456789 represents the business partner ID), even though you've maintaned the business partners 456789 and 123456 (123456 represents the business partner ID) as service technicians in the ticket 123. 

reply.jpglj,

Cause

Currently the WSDL QueryServiceRequestIn can only query the business partner of the main Party Role, not supporting a query for two business partner with the same Party Role.

Resolution

This is the system expected behavior.

If the feature/functionality is needed as a matter of urgency, please refer to KBA 3475641 - Functionality Currently not Available

Keywords

KBA , LOD-CRM-EMP , Employee , How To

Product

SAP Hybris Cloud for Customer add-ins 1708 ; SAP Hybris Cloud for Customer add-ins 1711