SAP Knowledge Base Article - Public

2552284 - Dropdown List Empty When Adding Pricing Condition in Contracts `No Item found`

Symptom

You have created a Contract and added Products in the Item Facet, when you try to click on the Add button in the Pricing facet you have an empty dropdown list with the message `No Item found`.

Reproducing the Issue

  1. Go to the Contracts work centre.
  2. Open the Contracts view.
  3. Open Contract ABC (ABC represents the Contract ID).
  4. Go to the Item Facet.
  5. Add Products.
  6. Go to the Pricing Facet.
  7. Click on the Actions Button --> Request External Pricing.
  8. After successful calculation click on the Add button in the Pricing facet.
  9. The Price component field, the drop down list is empty with message 'No Item found'.

Cause

Contract ABC uses pricing procedure XYZ (XYZ represents the pricing procedure used in the request). This pricing procedure wasn't used yet in the tenant.

The very first request of external pricing brings the allowed values for all further usages. However, these must be persisted.

Resolution

  1. Go to the Contracts work centre.
  2. Open Contract ABC.
  3. Go to the Pricing facet after adding Products in the Item facet.
  4. Click on Actions --> Request External Pricing.
  5. SAVE.

Close and reopen the Contract: The price component will be available in the dropdown list.

Note that is needed only once for any pricing procedure used for the first time. Hence, it will solve the issue also for all further Contract with this pricing procedure.

 

Keywords

KBA , LOD-CRM-EMP , Employee , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions