SAP Knowledge Base Article - Public

2553508 - User does not appear in search when searching for both (active and inactive)

Symptom

The Admin is unable to find the User in a search. Additionally, the User does not appear in the PA_STUDENT nor the PH_STUDENT tables.

Environment

SAP SuccessFactors Learning Management System (LMS)

Reproducing the Issue

  1. Go to Users->Users
  2. Select User Status as "Both"
  3. Search for the User
  4. The search returns "There are no records found."

When checking Audit records or in the database tables in PA_STUDENT and PH_STUDENT the user record also does not exist.

Cause

There are two possible causes:

  • The User was never created in the LMS.
  • The User was deleted and Purged (via Purge Deleted User Audit History APM)

Resolution

As the User was deleted and purged it is not possible to return the User for the system. Kindly create a new User with the desired information.

Keywords

Purge, Delete, User, DB, Database, Inactive, Active, Both, PA_STUDENT, PH_STUDENT, Automatic Process, APM , KBA , LOD-SF-LMS-COR , LMS Core - Items, Catalog, Curricula , Problem

Product

SAP SuccessFactors Learning all versions