Symptom
- Theme Manager changes aren't taking effect within the instance;
- Theme Manager not working properly;
- How do I enforce the Theme Manager changes to be applied?
- How much time does Theme Manager take to replicate changes across the system?
- Theme Manager are not replicating the changes in SuccessFactors?
- When you save the changes on the Theme Manager, you do not see any changes replicated on the instance theme.
Environment
SAP SuccessFactors HXM Suite
Reproducing the Issue
- Login within the instance;
- Access the Theme Manager;
- Change the theme settings as you wish;
- Save the changes;
- The changes weren't replicated yet.
Cause
The UI elements are stored on cache to save loading times, so the UI theme that is loaded on the browser may not be the one that you've just saved yet.
Resolution
To speed up the change's replication, you'll have the two below options:
- You can click "Try it now" (Just under the theme name) before you save it.
- This feature allow you to preview the changes that you are making, therefore, this will enforce the reload in the cache;
- You can logout and login back. This should also enforce the reload on the cache and then you will be able to see the changes.
Keywords
theme manager, theme manager issue, theme issue, theme manager changes, theme manager delay, try it now , KBA , LOD-SF-PLT-THM , Theme Manager Issues , LOD-SF-PLT , Platform Foundational Capabilities , How To
Product
SAP SuccessFactors HCM Suite all versions