Symptom
You want to deactivate Workflow Failed notifications for Key Users.
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Click on the Notifications icon.
- Observe many failed notifications for workflow rules.
Cause
The conditions for the Rule are met and the system is supposed to take action according to what has been set. When this happens, a Technical User takes the action, automatically, but as far as the system goes, it is the same as a regular user. The Failed notification comes when the object that is supposed to undergo action is locked by another User. Since the action cannot be taken, the system sends the notification to all users with Administrator Rights.
Resolution
This is a new feature introduced with the 1711 release.
To deactivate these notifications:
-
Go to the Business Configuration work centre.
- Go to the Implementation view.
- Click Edit Project Scope.
- Move to the Question facet.
- Expand Communication and Information Exchange.
- Expand Business Process Management.
- Expand Business Task Management.
- Check the option under General Settings for Tasks: C4C Specific.
Users can still navigate to the Administrator work centre and check the Workflow Logs to check failed messages.
See Also
KBA: 2433226 - Notification: Workflow Rule Failed
KBA: 3443823 - Definition of Key User for SAP Cloud for Customer
KBA: 2624275 - You Don't Want to Receive Failed Workflow Rule Notifications.
Keywords
Workflow, Log, Administrator, Business Task Management, Key User, Notification , KBA , workflow , deactivate , key user , failed notifications , LOD-CRM-WKF , Workflow , How To