SAP Knowledge Base Article - Public

2556644 - Emergency Contact 'Second Phone' information is only visible through details view

Symptom

EmergencyContactPrimary 'Second-Phone' information is only visible through details view and not displayed on Profile view

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Employee Central

Reproducing the Issue

1. Second-Phone when order is adjusted and set as mandatory in BCUI, this is not reflected on Employee Profile view.

BCUI.png

2. Profile View below

profile view non edit.PNG

3. When Details is selected, the Hierarchy order will be respected as shown below

Details view non edit.PNG

 

Cause

Second-Phone is a hard coded field and will only be visible through detailed view of the Emergency Contact.

Resolution

This is working as product design. Hard coded elements can not be custom.

Keywords

b1708 , PP3, Re-arranging fields in emergency contact portlet does not work, emergency conctact field display order, move fields from details to profile view , KBA , re-arranging fields in emergency contact , field display order , move fields from details to profile view , LOD-SF-EC-PER-ECO , Emergency Contact Details , LOD-SF-EC-PP3 , People Profile (PP3) , LOD-SF-EC-BCI , Manage Business Configuration (BCUI) & Data Models (XML) , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions