Symptom
The Site Locales page in Command Center controls the available locales and default locale of a site. In this context, when we consider a specific scenario which has the legacy RMK career site with jobs being imported from a third party ATS (Applicant Tracking System), it's important to ensure that all jobs contain a locale when defining a job import. However, in some situations a specific job imported might have a locale that's not enabled for the career site. In this situation an exception (errortype=exception) can occurs in the browser when an applicant try to access the job.
Environment
- Recruiting Marketing (RMK);
- Legacy Career Site.
Reproducing the Issue
- Look for a job in the career site;
- Click in the link pointing for the specific job;
- The following error occurs:
The page's content for this situation is normally blank. However the user can see some error information as follow:
Cause
The root cause for this error is the wrong locale associated to the job in the moment it was imported. We can confirm that by the URL which is pointing to a website directory related to a locale not configured whose the path has fr_FR as follow:
Resolution
Workaround until the next job import:
- Log in to Command Center and navigate to Jobs > Search;
- For each job with incorrect locale:
- Click the icon to the left of the title to open the Job Edit window;
- Change the locale to the correct one;
- Save;
- Close the windows.
Solution 1:
For each posted job in the ATS set the correct locale. Consequently, the next job import procedure it'll import the jobs with the correct locale.
Solution 2:
Open a case with Cloud Product Support in order to request to add the new locale to the career site. This type of change it'll be analyzed by the Development Team and can be charged.
See Also
Keywords
locale language issue, locale error, errortype exception, career site, legacy, RMK, Recruiting Marketing, Job Import , KBA , LOD-SF-RMK , Recruiting Marketing , LOD-SF-RMK-COR , RMK Core Platform , Problem