SAP Knowledge Base Article - Public

2557256 - Leads Duplicate Check Does Not Return Any Results

Symptom

Lead Duplicate Check does not return any results even when there is a Lead with the exact same information maintained.

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

  1. Go to the Sales work centre.
  2. Go to the Leads View.
  3. Select the New button.
  4. Enter a value in all the Mandatory fields.
  5. Select the Check for Duplicates button.
  6. No Data displayed.

Cause

A cause could be that PDI logic is maintained that has hidden the Name field in creation of a Lead ID. So when the Duplicate Check gets called there is no Name for the Lead. As the Name contains considerable weightage and given the other parameters for Duplicate Check are initial like Qualification Code, Priority, Category & Source are not entered, there is no match found.

Resolution

In order for the Duplicate Check to return the expected results, the Name field must be visible and include a value on Lead creation.

Keywords

Sales,  Leads, Check for Duplicates, No Data, Name , KBA , sales , leads , check for duplicates , no data , name , LOD-CRM-LM , Lead Management , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions