Symptom
You tried to run a report and get the error 'Hierarchy Account Hierarchy does not exist for InfoObject Account'.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Business Analytics work center.
- Go to the Design Reports view.
- Open report ABC (ABC stand for the report name/ID you want to run).
- After the report is loading for a while you will receive the following error messages:
- Report inconsistent. It cannot be started.
- Hierarchy Account Hierarchy does not exist for InfoObject Account.
Cause
There is a temporary inconsistency with this report at the moment.
Resolution
In order to resolve this, please do a dummy save and the report will be working fine again.
- Go to the Business Analytics work center.
- Go to Design Reports view.
- Select and edit the report ABC with the Report Wizard.
- Click finish and save the report without any changes.
- Run the report again and the report should work fine.
If this does not work:
- Go to the Business Analytics work center.
- Go to Design Reports view.
- Select and edit the report ABC with the Report Wizard.
- Go to Step 4 Characteristics Properties.
- Check if any Characteristics is set to Fix Hierarchy and the Hierarchy value is set correctly.
Keywords
Hierarchy Account, InfoObject Account , KBA , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , Problem
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions