Symptom
You noticed that for some users the report Account Details shows double values, compared to other users where the correct values are displayed.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
-
Go to the Business Analytics work center.
- Go to the Design Reports view.
- Open and run the report Account Details (technical ID BUPCSD_Q0001).
- You will see that the values for key figures like Share in store (%) or Share online (%) are displaying double the value but only for certain users.
Cause
The reason why the report shows the double values is because this problem occurs on data sources that return multiple rows per master data instance.
This is the case for the data source Account Details (technical ID BPCSDB) used by the report.
You can check this on your side when you open the account, which shows the incorrect values, and go to the tab account team.
Here you will see two entries for account team. This is the reason why the report shows double values for this particular account.
But why do we get different results with different users.
This is based on access rights, which means the report will check the access restrictions of the logged on user. According to the user's access rights the report result will be different.
Resolution
We would recommend a new report on the data source Account Master Data (technical ID CODCUSTOMER). Here the report will only return one row per account and the issue won't occur.
Keywords
KBA , access context , counter , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , How To