SAP Knowledge Base Article - Public

2558477 - Bank Statement Upload: Bank Account Missing or Cannot be Determined

Symptom

You are trying to upload a bank statement file, however the system does not find the bank account based on the income file, although it exists in the master data.

Reproducing the Issue

  1. Go to Liquidity Management work center.
  2. Go to Inbound File view.
  3. Create a new inbound file for bank statement upload.
  4. Attach the file.
  5. Click to start the file inport.

The following error messages are returned:

  • 'No bank account active on <date> for account number <bank account number>, national bank code <national bank code>, and currency <currency> found'
  • 'Bank statement ID $1 for bank account ID rejected'
  • 'Bank account missing or cannot be determined'
  1. Go to Liquidity Management work center.
  2. Go to MyBanks view.
  3. Open the concerned bank entry.
  4. Go to Bank Accounts tab.

You see that the bank account number mentioned in the error message is active and valid.

Cause

The national bank code/rounting number provided in the inbound file does not match with the number maintained in the bank directory of the house bank.

Resolution

If you are uploading a BAI2 US file for example, the national bank code is maintained in the File Header, record code 01, in the second position as well as in the Group Header, record code 02, in the third position. This must be a 9 digit ABA/FRB # as assigned by the federal reserve. Therefore, you need o check and update your file accordingly.

You may also verify the national bank code maintained in the system as follows:

  1. Go to Liquidity Management work center.
  2. Go to MyBanks view.
  3. Open the concerned bank entry.
  4. Under General tab, double-click the Bank ID field.
  5. Refer to the National bank Codes section of the bank directory that has been opened.

Keywords

KBA , AP-PAY-BS , Bank Statement , How To

Product

SAP Business ByDesign all versions