Symptom
When navigating to some users, you are unable to see their current Job Info Record and receive an application error on view of Job History.
Environment
Employee Central - Job Information
Reproducing the Issue
-
Navigate to a user
- You are unable to see their Job Information
- On Selecting the Job History Icon, you receive an Application error.
Cause
The issue can be caused by an incorrect manager value being maintained in the manager-id field.
When the system tries to search for the value maintained in the manager-id field they are unable to do so. This can be because, they are either not a valid user (may have been purged) or they are missing personal information).
To confirm this is the issue you can check via ad hoc report:
-
Create an Ad Hoc Report with the sub domain "Person and Employment Export"
- Provided a name to you report.
- On the "Columns" tab select all fields under "Employee Job Info"
- On the "Filters" tab, under "Employee Job Info" select the "user-id" field and search "By My Selection" for the impacted user.
- Save and Generate the report.
- Review the values maintained in the manager-id field.
- You may see Names maintained and not user-id's of the manager, alternatively review each manager, check that they are a valid user and have personal information with the same effective date as their hire date.
Resolution
- To resolve the issue you may need to correct the data via a Full purge Job History Import, if the issue is caused by Manage Names showing in the field, or purged users:
2201658 - Employee Central User Data Full Purge Import
You can use the report you generated in the pervious step to populate you import file or review the below KBA for further detail:
2266216 - How to Export Employee Central Data for Import Activities - If the issue is caused by missing personal information, you will need to provide personal information as of the hire date.
We provide a check tool to highlight this data issue for users in the system, so you can review for any further possible issues. If a users is/was a manager and has no personal information then this issue will occur for their direct reports history.
Check Tool: Employee Central Core > Personal Information > Everyone in Employee Central has Personal Information records.
See Also
CPS ONLY - Please review internal memo for error log example
Keywords
Application error, job history, job info, can't view, No row with the given identifier exists: [com.successfactors.user.bean.entity.UserSysInfoEO#, No row with the given identifier exists, UserSysInfoEO, UserSysInfoEO#, f008cb55ab66a8c7a111e9dbbc686e682a33da16, ingerprint=f008cb55ab66a8c7a111e9dbbc686e682a33da16, fingerprint=8a76e7420249c238de171db1948b32787b40852f , KBA , f008cb55ab66a8c7a111e9dbbc686e682a33da16 , LOD-SF-EC-JOB , Job Information , Problem