Symptom
You notice that the Workflow Rule created to trigger E-mail notifications is not adding attachments in the E-mails.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Administrator Work Center.
- Go to Workflow Rules View.
- Create a new Rule by clicking on New.
- When you reach 3 Define Actions, select Rule Type E-mail.
- Still in 3 Define Actions, tick the box Add Attachment.
- Finalise and run the Rule.
Result: The attachment was not included in the notification e-mail.
Cause
This is the current system behaviour.
Resolution
This feature requires an additional PDI enhancement that implements the logic to collect the documents and attach them to the e-mail. (ExitForGettingWorkflowAttachment)
See Also
KBA 2623964 - Unable To Send Attachments With Workflow Rules
Keywords
E-mail attachment, workflow attachment, workflow rule e-mail attachment , KBA , LOD-CRM-WKF , Workflow , How To
Product
SAP Cloud for Customer add-ins all versions