Symptom
You created a new account, and defined an address line with Bill-to and Ship-to purposes with value "Yes" to be the main Address of that account.
When trying to add a new address line and set one of the purposes to "Yes (standard)", the respective purpose of the already existing address changes to "No".
Reproducing the Issue
-
Go to Customers work center
- Navigate to Accounts view
- Enter Account ABC (ABC represents the name of the account)
- In the new screen, go to the tab Addresses
- Click on the Add button in the top right of the addresses section
- Enter the address data and click on Add
- In the new added address, define the Bill-to or Ship-to purpose to "Yes (standard)"
After defining the purpose, the value of the previously existing address changes to "no"
Cause
The issue occurs because the system works with the business principle of having only one address with purpose of bill and ship-to.
If you have one address which is already defined with bill-to as "yes", when you set a new one with value "yes(standard)" the system keeps the principle and sets the already existing one with value "no".
Resolution
This is the expected behavior of the system.
One way to avoid this from happening is to set the first address line with purposes set to "Yes (standard)". If you have one address line with this value, and adds a new row with value "yes (standard)", the other one will change it's value to "yes" instead of "no".
Keywords
KBA , AP-BP-CUS , BusinessByDesign: Customer , Problem