Symptom
'UserID' and 'Status' are displayed twice in different columns in the Basic User Info import template file.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
-
Employee Central
-
Import Employee Data
-
Basic import
Reproducing the Issue
-
Go to Admin Centre > Import Employee Data
- Click on the dropdown arrow in 'Download a blank CSV template'
- Select 'Basic Import'
- Downlaod and Open the CSV file
- Note that 'STATUS' and 'USERID' are displayed in Columns A and B respectively, but are also displayed in 2 other columns in the template file
Cause
This problem occurs when 'USERID' and 'STATUS' are defined as standard elements in the Succession Data Model. These fields are hard-coded and so do not need to be defined in the Succession Data Model as they will display as the first 2 rows in the Basic Import template file anyway.
Resolution
In order to remove the duplicate columns from the Basic Import template file, you will need to remove the defined standard elements 'UserID' and 'Status' from the Succession Data Model. This can be done via Manage Business Configuration or via a Data Model Upload in Provisioning;
Manage Business Configuration:
- Via Admin Center navigate to Manage Business Configuration
- Under the Employee Profile Section, expand View Template
- Select sysUserDirectorySetting
- Remove the userId and status fields using the trashcan
- Save
Data Model Upload:
- Access Provisioning > Succession Management > Import/Export Data Model
- Select 'Export File' > Submit
- Open the Export file and save a copy
- Search (using 'Ctrl + f') for <view-template id="sysUserDirectorySetting"
- Scroll down to the section where fields are being defined as '<standard-element-ref refid='
- Here, look for <standard-element-ref refid="userId"/> and <standard-element-ref refid="status"/>
- Highlight and delete these 2 lines only > Save this file
- Access Provisioning > Succession Management > Import/Export Data Model
- Select 'Import File' > Choose the saved file > Submit
Note: If you do not have access to provisioning please raise a ticket with SuccessFactors Support
Keywords
Employee Central, Basic User Info Import, Basic Import, UserID, Status, Duplicate, Import Template, Import Employee Data,sysAllUserDirectorySetting , KBA , LOD-SF-PLT , Platform Foundational Capabilities , LOD-SF-EC-EDP , Import Employee Data (EC Core only) , Problem