Symptom
Lead owner is changed to new owner, which do not generate notification for new owner.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Sales work centre.
- Go to Leads work centre view.
- Select and open Lead XXX, where XXX represents the ID of the lead).
- Edit lead.
- Change the Lead Owner to another Employee YYYYY, where YYYYY represents the name of the owner.
- Change in owner does not generate Notification for Employee YYYYY.
Cause
Notifications are not automatically generated for new owner when a lead owner is changed. This is current and expected behaviour.
Resolution
This is current and standard behaviour in Cloud for customer.
If you wish to execute this, then please execute following steps for the workaround to create a workflow rule that will generate a notification for the newly assigned owner:
- Go to Administrator work centre.
- Go to Workflow work centre view.
- Select New to create a workflow.
- Set the Business Object "Leads" and Timing "On Every Save".
- Set the condition for Field Owner. Check the Value Before Object Change checkbox. Compare Operator: Not equal to. With: Field Owner and select Next.
- Navigate to the Recipient Determination and select the value help.
- Choose the Marketing responsible Employee as this is the Owner.
- This will send a notification to the new owner.
Note: Notification workflows will NOT appear when executed in the Workflow Changes view of the object.
Keywords
Workflow, Lead notifications, Owner Change , KBA , change , notification , lead owner , new employee , LOD-CRM-LM , Lead Management , LOD-CRM-WKF , Workflow , How To