SAP Knowledge Base Article - Public

2560531 - On the Same Language Adaption, UI Texts IDs Differs From a Tenant to Another

Symptom

When accessing the language adaptation in a second tenant, you notice UI texts Ids differ.

Environment

SAP HYBRIS CLOUD FOR CUSTOMER

Reproducing the Issue

  1. Go to the Administration WorkCenter.
  2. Go to the General Settings view.
  3. Click on Language Adaptions.
  4. Click open any language adaptaion.
  5. Click on the Collect Texts button.
  6. Go to the UI text facet.
  7. Check the UI text IDs of the desired Field.
  8. Log into another teant, and proceed to the same steps.

Result: Some UI texts IDs differ from a tenant to another.

Cause

With respect to UI Texts, Code Texts, Message Texts:

The text ID's are always the same in all systems for all texts delivered by SAP. However, they are not necessarily the same for texts created via Key User tools or PDI.

Please Note : Only if there is a 100% parity between two systems (in terms of Change Transactions and PDI solutions), then the custom texts would have the same ID's.

With respect to Report Texts:

SAP does not generate any UI text Ids. This UI text is taken from the base Business Object field.

Resolution

The UI text ID's are always the same in all systems for all texts delivered by SAP; however, some may differ if created via the Key User Tool or PDI.

Keywords

UI Texts, Code Texts, Message Texts, Key User tools, Language Adaptation. , KBA , AP-RC-TXA , C4C Text Adaptation , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions