SAP Knowledge Base Article - Public

2560803 - Field Rules Are Not Working on Tickets

Symptom

You try to create a rule for a field that is not present on header level or the tab that is loading by default when the Ticket TI is open.

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

  1. Open Service work center.
  2. Go to the Tickets view and open any ticket.
  3. Navigate to the tab you want to create the rule.
  4. Click on Adapt.
  5. Click on Edit Master Layout.
  6. Hover the mouse over the field you want to create the rule.
  7. Click on Change Properties.
  8. Click on Rule and try to create the rule.

Cause

The rules are created to work with 1:1 fields which are present in the header or the facet which loads by default when the TI opens.

Resolution

Due to the lazy loading, it is not possible to use those fields which are available in other tabs.

Keywords

field rules, tickets , KBA , AP-RC-UIF-FLX , Page Layout & Key User Configuration , Problem

Product

SAP Cloud for Customer add-ins 1802 ; SAP Cloud for Customer add-ins 1805 ; SAP Cloud for Customer add-ins 1808 ; SAP Hybris Cloud for Customer add-ins 1702 ; SAP Hybris Cloud for Customer add-ins 1708 ; SAP Hybris Cloud for Customer add-ins 1711