SAP Knowledge Base Article - Public

2561797 - Partner Contact Details are not Available in the Migrated Opportunity

Symptom

You require to migrate Opportunities with a Party Role Partner Contact. Upon adding the Party Role Partner Contact inside the Involved Parties sheet, it adds a record with role Partner Contact in the Sales Team facet of the Opportunity, but it does not show the Name, Email and Phone of the Partner Contact.

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

To migrate Opportunities:

  1. Go to Business Configuration work center
  2. Select Implementation Projects view or Overview
  3. Search and Open the activity Migration of Opportunities
  4. Select Migrate opportunities using the migration tool
  5. Upload the Migration File
  6. Execute Migration for the respective Migration File with Migration Mode Add new records
  7. Migration is Completed

 To check the availability of the migrated Opportunity ID: XXXXX (where XXXXX represents the Opportunity ID)

  1. Go to Sales work center
  2. Go to Opportunity view
  3. Search for the Migrated Opportunity XXXXX
  4. Open the Opportunity and go to the Sales Team tab

Line item is available for the Role Partner Contact. But the Name, Email, Phone are not available for this Partner Contact XYZ (where XYZ represents the Partner Contact), even if the same details are maintained in the Partner Contacts view in Partners workcenter.

Cause

Issue is because there is no Business Partner with ID YYYYY in the system.

Resolution

You may check the Party ID provided in the Migration File. If it is an External ID, then the value mapping in Migration workbench is incorrect.

Provide the Business Partner ID YYYYY in the Party ID field in the Migration File.

Keywords

Business Partner ID, Partner ID , KBA , business partner id , partner id , LOD-CRM-OPP , Opportunity Management , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions