Symptom
You require to migrate Opportunities with a Party Role Partner Contact. Upon adding the Party Role Partner Contact inside the Involved Parties sheet, it adds a record with role Partner Contact in the Sales Team facet of the Opportunity, but it does not show the Name, Email and Phone of the Partner Contact.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
To migrate Opportunities:
- Go to Business Configuration work center
- Select Implementation Projects view or Overview
- Search and Open the activity Migration of Opportunities
- Select Migrate opportunities using the migration tool
- Upload the Migration File
- Execute Migration for the respective Migration File with Migration Mode Add new records
- Migration is Completed
To check the availability of the migrated Opportunity ID: XXXXX (where XXXXX represents the Opportunity ID)
- Go to Sales work center
- Go to Opportunity view
- Search for the Migrated Opportunity XXXXX
- Open the Opportunity and go to the Sales Team tab
Line item is available for the Role Partner Contact. But the Name, Email, Phone are not available for this Partner Contact XYZ (where XYZ represents the Partner Contact), even if the same details are maintained in the Partner Contacts view in Partners workcenter.
Cause
Issue is because there is no Business Partner with ID YYYYY in the system.
Resolution
You may check the Party ID provided in the Migration File. If it is an External ID, then the value mapping in Migration workbench is incorrect.
Provide the Business Partner ID YYYYY in the Party ID field in the Migration File.
Keywords
Business Partner ID, Partner ID , KBA , business partner id , partner id , LOD-CRM-OPP , Opportunity Management , Problem