SAP Knowledge Base Article - Public

2562005 - There is no Data to be Visualised on Tile in Dashboard

Symptom

Certain users get the following message in Dashboards / tiles:

"There is no Data to Be Visualised"

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors HXM Suite

Reproducing the Issue

Access the respective tile on the Homepage.

test tiles.png

Cause

The tile's default people scope is set to 'Team View' and the user under concern doesn't actually have a team reporting to her / him.

Resolution

Check if the User has the ability to access reporting data for a specific report or employee.

  1. Click the 'There is no data to be visualised' text to expand the tile.

    expandTile.png
  2. Expand / display the filters by clicking the 'Filter' icon
  3. Click the 'Report Type' dropdown
  4. Select 'Other Filters' from the list
  5. Apply Filters

    teamView_Filter_Change.png

  6. Now check if the Dashboard is populated. The user does not have the permission to view data for a specific report or employees or user does not have "Team"
  7. More details on users permission can be obtained using the "User Role Search" function in Admin Center (Note that Admin permission is required to access this function).

See Also

2229272 - User Role Search - How to check if a User has a Permission (for example Report permission)?

Keywords

Dashboards, There is no Data to be Visualised, Error, Report, Permission, Team, View, People, scope, filter , KBA , LOD-SF-ANA-DSH , YouCalc Dashboards and Tiles (Dashboards 2.0) , LOD-SF-ANA , Analytics & Reporting (Ad Hoc, YouCalc, ORD) , Problem

Product

SAP SuccessFactors HCM suite all versions