Symptom
Your User Update Run log displays following warning message: "View ABC can't be assigned since no restrictions could be determined" (ABC represent the name of the work centre view).
Environment
SAP Cloud for Customer
Reproducing the Issue
Prerequisites:
You created a Business Role, assigned it to a Business User and used the Update Users functionality to trigger the User Update Run.
- Go to the Administrator work centre.
- Select the General Settings view.
- Click the Business Roles hyperlink, under the Users section.
- Select and open the relevant business role.
- Click the View All button.
- Click the Assigned Users button.
- Choose the Show Background Runs option.
- Click the Display Log button.
- Select the Results facet
- OR: under the Assigned Business Users tab, select the relevant user.
Here you see following warning message displayed: "View ABC can't be assigned since no restrictions could be determined."
Cause
Depending on the chosen restriction rules the system searches if the Organisation to which the User is assigned is marked as Sales or Service Organization.
If the flag is missing, the work centre view will not be assigned to the user.
Resolution
Please use the following steps to solve the issue:
- Go to the Administrator work centre.
- Select the General Settings view.
- Click the Org Structures hyperlink, under the Company section.
- Select and open the relevant org structure.
- Select the Functions facet.
- Click the Edit button.
- Set the relevant flag(s).
- Save the changes.
Keywords
User Update Run, Work centre view, Access Restricion , KBA , user update run , view abc can't be assigned since no rest , work centre view , access restricion , LOD-CRM-ACC , Account , How To