Symptom
You are trying to create Service Requests, but the system shows the error message below:
"Please enter a party with role Account"
Environment
SAP Hybris Cloud for Customer 1711 and higher.
Reproducing the Issue
-
Go to Business Configuration Overview view;
- Search for Migration of Service Request;
- Click and open the Migration Tool;
- In the step of Simulation the system is showing the mentioned error message.
Cause
The reason for that is in the way that Migration Tool works, if it does not receive a Business Partner Internal ID, it is not able to create/process this document correctly.
Resolution
This is a standard behavior. To avoid the mentioned error message you have to maintain information in the field Account ID of the migration template.
The solution is also vaild while creating Tickets using web services.
Keywords
Migration; service; requests; tickets; , KBA , AP-SRP-SR , Service Request , Problem