Symptom
Admin set the value of the catalog results property to card or list but users can change Card or List view in LMS Catalog Search
Environment
SuccessFactors Learning Management System
Reproducing the Issue
You can find the value in the following location in LMS -
Login as a LMS Admin->System Admin->Configuration->System Configuration->CATALOG->catalogResultsViewMode
Cause
This is the expect behavior
Resolution
Admins can set a value at catalogResultsViewMode (either 'Card' or 'List') and this value is applied to users who never changed their view themselves (applies for the new users as well) and the moment the users change the view as per their preference, they would have the view depending on the view that the users choose
Keywords
catalogResultsViewMode, Card view, list view, user catalog view , KBA , LOD-SF-LMS-CAT , Catalog , Problem