Symptom
User is not being assigned Items, Curricula and/or Programs by the Assignment Profile, even though the user seems to match the Rules.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Open an Assignment Profile record
- Click the Rules section
- Check the Rules and see if the mentioned Users matches the Rules
- The Assignment Profile has been propagated
- Go to the Assignment Profile tab on the User record and AP is not listed
Cause
- The user must match the Security Domain and all rules of a group
- The user must not have been assigned the item, curricula, or program by the AP and unassigned manually by an admin
- The value placed in the rule for a custom field is not correct. The values are case sensitive.
Resolution
Please make sure to do due diligence before engaging SAP Support. SAP Support should not be engaged with configuration issues.
Section 1: Security Domains
- Security Domains are checked for all users. As a user cannot have multiple Security Domains, in the above example, the Assignment Profile will check all three of the domains listed there.
- This is the first place to cross reference a user that you are expecting to be associated to the AP and validate that the Security Domains listed match the one the user has associated on the User Details tab of the User Record.
- If "(includes security subdomains)" is mentioned next to the Security Domain, make sure to validate all the subdomains that are part of that Security Domain by accessing the Security Domain record in System Administration > Security > Security Domains > access the record > Summary tab.
Section 2 & 3: Rules
- Not all AP rules have multiple groups. The way an AP works with multiple group of rules is that the user must first match the Security Domain and one of the group of rules. The different group of rules work in an OR relationship.
- Two example users:
- UserID: userID123, City: London, Security Domain: Steel Workers, Address: North Pole
- UserID: UserXYZ, City: London, Security Domain: Default Public Access Domain, Address: North Pole
- Once this AP is executed to propagate, it will only assign to UserXYZ. While userID123 meets the criteria of the first group of rules (section 2), they do not meet the Security Domain. UserXYZ matches the Security Domain and matches the second group of rules (section 3) so they will be associated to the Assignment Profile
Custom Field Rules
A common issue that is seen is associated to non-referenced custom fields. When a custom field is not referenced, the field is treated as a free text area, which means that the value that is on the User Record and AP Rule must be exact. There should be no spaces before or after the value and the value is case sensitive. Utilizing the same example as above screenshot, adding in a custom field rule.
User Information:
- UserID: UserXYZ, City: London, Security Domain: Default Public Access Domain, Address: North Pole, test custom field: Value1
While all the rules look correct, the user was not assigned to the AP due to the values being typed/added improperly on the AP rules or on the user record. Here is a screenshot of the value on the user record:
As it might not evident unless highlighting the text, there is an additional space after the text. The AP rules are looking for "Value1" while the user record has "Value1 ". For custom fields, find the source that is storing the value and update it there, manually updating the user record will not resolve the issue in the long term. If the custom field is managed in Employee Central and the user data from Employee Central is passed through an Employee Export job for the SF User Connector, the data on Employee Central must be corrected first.
Keywords
AP, Assignment Profile, Domain, Not assigning, Item, Curricula, Program, Match Rules, Security Domain , KBA , LOD-SF-LMS-ASP , Assignment Profile , How To