Symptom
The user is assigned to an item, which gets a completion granted. However, the assignment remains on the user's Learning Plan (and at the 'Assigned Items' tab). What can be done so that the completion removes the item from the user's Assigned Items?
Environment
SAP SuccessFactors Learning
Cause
This scenario happens when the assignment has an Assigned Date later than the Completion Date recorded in the Learning History.
Resolution
Below you can see some options to address the issue. Which one to use depends on each customer's requirements:
- Edit the completion event to have a Completion date that's later than the item's Assigned date. With that, the item will be removed from the 'Assigned Items' tab and will remain only at the 'Completed Items' tab;
- For more details about it, please check Editing Closed Classes.
- Record a new completion event, making sure the Completion date is later than the Assigned date. With that, the user will have two completion events for the item;
- Completions can be recorded through different paths:
- Simply remove the item from the 'Assigned Items' tab. With that, the item will no longer be in the user's Learning Plan, and will remain in the Learning History;
- Remove the item from the 'Assigned Items' tab and assign it again, making sure to edit the Assign date to be before the item's Completion date;
- For more details, please check 2543971 and Assigning Users to Learning Needs in Bulk.
Alternatively, to have a different system behavior, it would be possible to have an enhancement request created for it (as per KBA 2090228), where the Learning Product Management team can further review and assess the requested functionality to be considered in a future release.
See Also
Keywords
sf, sfsf, learning, lms, assigned, items, date, completed, completion, removed, marked, readded, assign, event, editor, Assigned Items, Completed Items, assignment, , KBA , LOD-SF-LMS-ADM , System Admin, Global Variables, References , LOD-SF-LMS-ITE , Items , LOD-SF-LMS-USR , User Entity , Problem
SAP Knowledge Base Article - Public