Symptom
- When accessing the Signature Step in Onboarding (with DocuSign enabled), you are receiving an error preventing you from proceeding.
- DocuSign yielding an error for new hires in locales others than United States English
- Error occurred while processing DocuSign request. Please, refresh the page and try again. Refresh page.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Onboarding 1.0
Reproducing the Issue
- Login and navigate to SAP SuccessFactors
- In Onboarding, process any activity prior to/or during a signature stage; it may also be experienced in a DocuSign notification for signature to be executed (Remote Signing)
- An error message will show 'Asynchronous task is completed with error.'; the error message is a generic DocuSign message
Cause
Integration connection between Onboarding and Docusign when sending notification.
Resolution
To resolve the issue, an option in DocuSign Administration needs to be enabled. Please follow the steps below on how to turn on the setting required to avoid the error.
- Login and navigate to DocuSign and access Administrative function; see image referenced below
- Under Signing and Sending section in the left pane, find Enable custom email and language for each recipient
- Tick the checkbox Enable custom email and language for each recipient
- Create a new Onboarding Activity and test again.
Keywords
sf, success factors, ONB, OBD, on boarding, Docu Sign, DocuSign signature, DocuSign notifications, Onboarding to DocuSign integration, 'Asynchronous task is completed with error., KMS.XpressHR.Tasks.DocuSignUploadAsyncTask, An error occurred while executing DocuSignUploadAsyncTask., 00000000-0000-0000-0000-000000000000, UncompletedSection2, Error=[Can't create envelope . Error:Account or user does not have permission to set recipient email notifications.] , KBA , LOD-SF-OBD-DSN , DocuSign , Problem