Symptom
You want to enhance the AWS Email Feeder to have a predefined From address using a BAdi.
Environment
SAP Hybris Cloud for Customer
SAP Cloud Application Studio
Reproducing the Issue
- Go to the Service work centre.
- Go to the Ticket view.
- Open any Ticket.
- Scroll down the Overview facet to the AWS Email Reply.
- Click on the Forward button.
- Observe the From field.
- Open the SAP Cloud Application Studio.
- Add a new Item Extension of the type Enhancement Implementation.
- Search for the Enhancement Option ServiceRequestAgentWorkSpaceUIManageFeatures.
- Observe the Inputs and Outputs available for this BAdi.
Your required behaviour is not feasible.
Cause
The BAdi ServiceRequestAgentWorkSpaceUIManageFeatures can influence only two features of the feeder in the HTML Ticket UI.
- Disable the Feeder by setting the Parameter DISABLE_EMAIL_REPLY.
- Set the Default TO address by setting the Parameter DEFAULT_EMAIL_TO.
This BAdi is called whenever the HTML5 Ticket UI loads after a round trip has happened to the backend from the UI.
This means as a whole that the BAdi does not get triggered when clicking a button on the Feeder to open.
Resolution
This BAdi can not influence the FROM address currently. This would be a new requirement.
See Also
BAdi Information:
- Enhancement Option: ServiceRequestAgentWorkSpaceUIManageFeatures
- Enhancement Spot Technical Name: ES_COD_MANAGE_AWS_FEATURES
- Two Influences: Set default TO email address / Disable feeder
Keywords
Service, SAP Cloud Application Studio, Enhancement Implementation, ServiceRequestAgentWorkSpaceUIManageFeatures , KBA , LOD-CRM-SRP , Service Request Processing , Problem