Symptom
Getting a blank error message while trying to save the home address for an employee
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors Employee Central
- SAP SuccessFactors HXM Suite
Reproducing the Issue
- Go to Employee Profile
- Click on "edit" Address portlet
- Change employee home address and save
- The system will trigger a blank error message
Cause
The country specifcs "country" field is not set up correctly. The field is not referencing any picklist for country field.
Resolution
Set up the country specifics "country" field with correct country picklist
- Go to Manage Business Configuration
- Select the desired Country Specific Home Address
- Click on "country" field details
- Set "Type of Reference Object" field as "Picklist"
- Set "Picklist" field as "country"
- Save
Keywords
blank, error, homeAddress, home, address, country, ECT-72096, employee central, employee profile, successfactors, SF, EC , KBA , LOD-SF-EC-PER-ADR , Home Adress - Config, Rules, RBP, UI , How To