SAP Knowledge Base Article - Public

2566712 - Blank error message while saving Home Address

Symptom

Getting a blank error message while trying to save the home address for an employee

2017-11-19_17-40-58.jpg

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP SuccessFactors Employee Central
  • SAP SuccessFactors HXM Suite

Reproducing the Issue

  1. Go to Employee Profile
  2. Click on "edit" Address portlet
  3. Change employee home address and save
  4. The system will trigger a blank error message

Cause

The country specifcs "country" field is not set up correctly. The field is not referencing any picklist for country field.

Resolution

Set up the country specifics "country" field with correct country picklist

  1. Go to Manage Business Configuration
  2. Select the desired Country Specific Home Address
  3. Click on "country" field details
  4. Set "Type of Reference Object" field as "Picklist"
  5. Set "Picklist" field as "country"
  6. Save

2017-11-19_17-42-09.jpg

Keywords

blank, error, homeAddress, home, address, country, ECT-72096, employee central, employee profile, successfactors, SF, EC , KBA , LOD-SF-EC-PER-ADR , Home Adress - Config, Rules, RBP, UI , How To

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HXM Suite 1911 ; SAP SuccessFactors HXM Suite 2005 ; SAP SuccessFactors HXM Suite 2011 ; SAP SuccessFactors HXM Suite 2105 ; SAP SuccessFactors HXM Suite 2111 ; SAP SuccessFactors HXM Suite 2205 ; SAP SuccessFactors HXM Suite 2211 ; SAP SuccessFactors HXM Suite 2305 ; SAP SuccessFactors HXM Suite 2311