SAP Knowledge Base Article - Public

2567420 - C4C Contact is not available in Recipient Determination for a WorkFlow

Symptom

In the recipient determination of a workflow you are not able to see C4C Contact in the drop down, when the rule type is activity task

Environment

Cloud for Cusotmer

Reproducing the Issue

  1. Go to Administrator work center
  2. Go to Workflow Rules facet
  3. Select Show all and find for ABC (ABC is the name of the Workflow rule)
  4. Select Edit
  5. Navigate to Step 3 Define Actions
  6. Go to the section Recipient Determination

In the drop down, recipient determination isn't showing C4C contact as an option

Cause

The reason C4C Contact doesn't appear for Activity Task is that a processor of the Activity Task can only be an employee and not a contact. So all the determinations (including Partner Contact) which returns the person with the role as employee will appear in the list and the determinations which return any other role will not be visible.

The same happens for E-mail: the Contact option will not be available for Recipient Determination.

Resolution

This is the expected system behavior.

Keywords

Workflow recipient determination C4C Contact , KBA , workflow , recipient determination , define actions , c4c contact , activity task , LOD-CRM-WKF , Workflow , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions